欢迎

iSmartMate用户手册

  • iSmartMate为UPS辅助的关机程序，可安装于网络的windows系统计算机上，通过SNMP网口转换卡与UPS相连，当iSmartMate通过固定IP和端口接收到由网络上的UPS所送出的市电故障，电池故障和UPS故障等讯息时，可保存和记录文档后，安全得关机。

  • 此用户手册含以下各项的说明:
    • 系统支持
    • 功能简介
    • iSmartMate安装与卸载
    • iSmartMate主界面窗口说明
    • iSmartMate操作说明
    • 帮助


功能简介

功能简介
  • 支持RFC1628的SNMP协议远程监控UPS
  • 可监控UPS的各种故障信息，功能使能设置和关机时间设置
  • 可选择关闭系统前自动保存重要文档，进入休眠状态等方式
  • 在关机或者休眠之前若故障解除可自动恢复正常
  • 可以记录关机前文档档案，用户可通过关机档案查询记录
  • 支持任务栏隐藏模式运行，告警后可弹出告警信息
  • 联机断开后可自动连接，并且有开机自动启动功能
返回目录


系统支持

iSmartMate使用手册
系统支持
  • 硬件需求:
    • 1. 计算机：支持RS232或者USB通信。
    • 2. 连接线：UPS专用RS232 的9PIN串口线或者USB连接线， 对于使用RS-232串口通讯的客户，将母的一端接在系统上的RS-232通讯口上, 若系统只有25PIN的通讯扣, 可用9PIN对25PIN的转接头来连接；对于使用USB通讯的客户， 只需用专用的USB数据通讯线将电脑与UPS连接即可。
    • 3. UPS：支持串口协议通信的UPS。
  • 适用操作系统:
    • 1. Microsoft Windows 95
    • 2. Microsoft Windows 98
    • 3. Microsoft Windows NT
    • 4. Microsoft Windows 2000
    • 5. Microsoft Windows 2003/2008/2012
    • 6. Microsoft Windows Me
    • 7. Microsoft Windows XP（32/64）
    • 8. Microsoft Windows Vista（32/64）
    • 9. Microsoft Windows 7（32/64）
    • 10. Microsoft Windows 8（32/64）
    • 11. Linux (32/64)

  • 注：软件支持但不限于以上系统。


安装与卸载

安装与卸载
  • 在Windows下安装iSmartMate
    • 将光盘放入光驱中，点击iSmartMate.exe图标，然后进入到安装向导过程,如图所示。
  • 在LINUX下安装iSmartMate
    • 将iSmartMate.bin文件拷贝至相应安装目录下，在Terminal终端使用sh iSmartMate.bin命令，即可进行安装，详细安装请参考linxu文件夹。
  • 启动iSmartMate
    • 1. 安装完成后，在系统桌面产生应用程序的快捷方式并且在系统开始菜单栏产生登录快捷方式。
    • 2. 软件启动后，在菜单栏内可以看到程序图标。
    • 3. 软件打开后，会显示出软件的主界面，并且在任务栏中会出现如下界面：
    • iSmartMate与UPS正常连接
      iSmartMate与UPS通信异常
      iSmartMate与UPS失去连接
  • 卸载iSmartMate
    • 若要卸载iSmartMate，则在iSmartMate程序组里选择"卸载iSmartMate"并确认即可完成删除。
      • help_cn:点击后，打开中文版用户手册
      • help_en:点击后，打开英文版用户手册
      • iSmartMate:点击后，进入主程序。
      • 卸载iSmartMate:点击后，进入卸载程序。


主界面说明

主界面说明
  • 进入iSmartMate后会出现如下所示主界面:
    图1: iSmartMate主界面
  • 主窗口说明：
  • 界面部分 | 功能分类 | 详细说明
    网络状态 | IP | 被监控UPS对应的IP地址
    UPS状态 市电故障 当市电断开，UPS进入到电池模式

    红色：告警

    绿色：正常

    灰色：未使能
    电池电压低 | 在电池模式下，电池电压或容量低
    UPS故障 | UPS出现故障的告警
    实时事件 | 联机实时记录 | 实时记录联机的时间，联机状态，IP
    状态栏 | 当前时间 | 显示当前实时时间信息
    关机倒计时 | 显示关机倒计时的时间
    代理和UPS的状态 | 显示代理和UPS的连接状态

    安装操作

    界面触发

             设置 IP，SNMP版本，关机保存路径，关机运行外部命令，关机时间，开机自动运行程序选择和弹出报警对话框的设置
    关闭 | 上次关机的时间、程序以及保存的文件
    日志 | 查询联机实时记录的事件日志和故障信息
    帮助 | 点击帮助,可以看到软件版本及版权等相关资料


操作说明

操作说明
  • 设置IP地址、对SNMP版本的选择、选择关机保存路径、可执行的外部命令，关机时间设置和弹出报警框的时间设置
    用于保存上次关机的时间、关闭的程序和保存的文件
    记录UPS和代理的状态及当前的时间
    显示iSmartMate软件版本及版权等相关资料，及打开用户手册


关闭

关闭
  • 图1：关闭文件
  • 1. 上次关机时间
    • 显示系统上次关闭时的系统时间。
  • 2. 上次关闭的应用程序
    • 显示关闭操作系统时，系统正在运行的应用程序。
  • 3. 上次保存的文件
    • 显示关闭系统时，软件帮助保存的文件，保存文件的格式与具体系统有关，通常可以保存office文档、txt等，文件保存的路径在设置的电源设置选项中设置。
返回上一层


日志

日志
    • 记录UPS和代理的状态及当前的时间。
    • 图1：日记窗口
返回上一层


设置

设置
  • 1. SNMP设置
    • 设置IP地址和对SNMP版本的选择。
    • 图1：SNMP设置
  • 2. 电源设置
    • 选择关机保存路径、可执行的外部命令，关机时间设置和弹出报警框的时间设置。
    • 图2：电源设置
返回上一层


帮助

帮助
  • 点击帮助,可以看到iSmartMate软件版本及版权等相关资料。
    图1: 关于iSmartMate画面
  • 点击用户手册，可以打开用户手册进行阅读。